
Using GIMP to Create an Artistic Regional 
RPG Map – Part 1 
This tutorial series is an updated and revised edition of an original tutorial created by RobA for the 
Cartographer’s Guild (www.cartographersguild.com). Updates and revisions to the instructions, along 
with new screenshots, were created by Megan Wiseman (“wisemoon” on Cartographer’s Guild). 

Introduction to the Revision 
RobA created a marvelous tutorial for creating a great-looking map using GIMP. However, some 
elements of the tutorial were somewhat confusing. As a technical writer, with 14 years of experience in 
writing manuals, technical documents, and tutorials, I felt I could clean up the steps, add more 
screenshots, and update the instructions to match a more recent version of GIMP (the version I have is 
2.6). I hope this revision will be even more helpful to members of the Cartographer’s Guild community 
than the original tutorial was. 

RobA’s Introduction 
First off, let me say that it was Pyrandon’s city map tutorial that inspired me to write up this one, so I 
will steal his format. I have been working on a variety of techniques to make what I consider to be “nice 
looking” maps using GIMP, and I feel the techniques are polished enough now that anyone can follow 
along and create one too. 

I intend to publish this tutorial serially, in the How-To forum at the Cartographer’s Guild website, and 
hope to coalesce it into PDF form for download when complete. 

Why GIMP? 
In case you aren’t aware, GIMP (GNU Image Manipulation Program)is a raster graphic editor, similar to 
Adobe Photoshop. GIMP is free software, available under the GNU General Public License, and can be 
downloaded from www.gimp.org in versions for a variety of operating systems, including Windows and 
Linux. 

This tutorial has been developed with GIMP version 2.6, and may refer to features not available in older 
versions. Additionally, menus may have been altered in this or previous versions, so if you have an older 
version you may have to look around the interface, if the menu options in the tutorial don’t match what 
you have. Most of the techniques in this tutorial have equivalents in Photoshop, Paintshop Pro, and 
other raster editors. Naturally, if you have something other than GIMP you will have to do some fiddling 
to discover how to use the technique described in your editor. 

http://www.cartographersguild.com/
http://www.gimp.org/


The features and techniques that will be used in this tutorial series are: Layers, Layer Blending Modes, 
Layer Masks, Blur filters, Noise/Cloud filters, Gradient Mapping, Bump/Displacement Mapping, Channels 
and Paths. 

How Well Do I Need to Know GIMP? 
Everything will be explained methodically, in a numbered step format. This will make it easy to refer 
back to previously used techniques and features. Additionally, there are plenty of screenshots included 
to help you locate menu options, show examples of techniques used, and show you results. 



What Type of Map Will I Be Making? 
By following this tutorial, you will be creating a map similar to the one shown below: 

 



[Ed note: update picture when map is complete]This type of map is ideal for showing large overland 
areas where details such as mountain ranges, large bodies of water, roads and forests are displayed. An 
example would be the map of a particular nation, or the regional area containing multiple tribes. The 
techniques in this tutorial do not work as well for world maps, or local maps. 

What Do I Need to Begin? 
To complete this tutorial series, you need the following: 

1. A copy of GIMP installed on your machine. 
2. An idea for a map, such as a rough pencil sketch showing the general shape of the land and the 

location of major geographical features. Detail is not necessary at this point. If you don’t have a 
sketch ready to hand, the tutorial will include some techniques for generating a new map 
randomly. 

3. A color scheme. This will give the map a unique and recognizable appearance. For convenience, 
this tutorial uses the same color palette that Pyrandon used for his city map tutorial. This palette 
is attached to the tutorial thread and can be downloaded.  

 

Before You Start 
This section of the tutorial shows you how to set up GIMP properly for the rest of the tasks you will be 
performing. 

The Color Palette 
In the same thread as this tutorial, you can find a ZIP file containing the City-Map-Colors.gpl file. 
Download and extract this file to the following directory: 

• For Windows 7:  

C:/Users/yourusername/.gimp-2.6/palettes (where yourusername is whatever username you use on 
your computer) 

• For earlier versions of Windows: 

C:/Documents and Settings/yourusername/palettes 

Once you have placed the palette file into the correct folder, GIMP will locate and load it the next time it 
is opened. 

Setting Up Windows 
When you open GIMP, you might notice that unlike most Windows applications, the dialog boxes and 
images are each in their own window. This can be difficult to get used to. Make sure that you have the 
following dialogs open: 



• Tools 
• Layers/Channels/Paths/History 
• Brushes/Patterns/Gradients 

If any of these are not open, you can open them manually by following these steps: 

1. In the main image window, click Windows>Dockable Dialogs>Layers (or whatever dialog you need 
to open). This is shown in the screenshot below. 

  

2. If you want to add the dialog as a tab in a window that is already open, right-click the small arrow 

 to the right of the dialog name, to open the menu for that dialog. 
3. Click Add Tab, and then select the name of the dialog box you want to add. This is shown in the 

screenshot below. 

 

 

 



Here are a few other useful dialogs you might want to open while you are working: 

• Histogram 
• Palette Editor 

Starting with a Sketch 
In this first section, you will learn how to start your map using a rough sketch. Here is the sketch used in 
this tutorial. It is a piece of a larger, hand-drawn continental map. This region once belonged to an 
ancient empire, so I am calling it “Old Pargeanon”. 

 

1. If your sketch is already a digital file, open it in GIMP. If it is hand-drawn, scan the sketch and 
save it as a JPG, then open the file in GIMP. 

2. If your sketch is smaller than you want the final map to be, you can scale up the image. Click 
Image>Scale Image. This opens the Scale Image dialog box. 

3. In the Scale Image dialog, you can select the size for your enlarged image. You can click the 
arrow keys to change the Width and Height manually, or you can select the number and type in 
a new one. To the right of the Width and Height fields is a unit of measurement field. The 
default is set to pixels, but you can click the dropdown box to change to a different unit, or 
choose to increase the size by percentage. You can change the resolution for the enlarged 
image in the X resolution and Y resolution fields. The Interpolation field determines how much 
data is included in the enlargement. Cubic is the default setting and gives you the highest 
quality. 



4. Once you have your image at the size you want, create a new layer and label it “Land”. You can 

create a new layer by clicking the New Layer icon in the Layers dialog, or by going to the 
main image window and clicking Layer>NewLayer. 

5. In the Tools dialog, click the Pencil tool. In the settings section at the bottom, choose a large 
solid brush, such as a solid Circle (15). 

6. Use the Pencil tool to trace the outline of your map, on the new layer you created in step 4. 
Make sure your outline is completely closed, with no gaps. 

7. Select the Magic Wand tool from the Tools dialog, and click inside your outline. This will 
select the entire area inside the line. 

8. Change to the Bucket tool, and click inside the selection. This will fill in your selection with black. 
Make sure all land areas on your map are filled with black. 

9. If you have a coastline, use the techniques in steps 7 and 8 to fill your sea/ocean area with 
white. Make sure nothing is selected by clicking Select>None. You should end up with 
something that looks similar to the image below. 

 



• IF your map does not have a coastline, skip to step [insert number here].  
• IF your map has a coastline, continue to step 10. 
10. In the main image window, click Colors>Invert. This turns your landmass white and your water 

mass black. 
11. In the main image window, click Filters>Blur>Gaussian Blur. This blur filter will randomize the 

edge of the coastline, to make it more realistic. If you have a fairly detailed coastline already, 
with lots of islands etc., use a smaller blur setting. In the example, a 50 pixel setting was used. 

 

 

12. Create a new layer and label it “Land Noise”. In the main image window, click 
Filters>Render>Clouds>Solid Noise. This opens the Solid Noise dialog. 

13. In the dialog, change the Detail to 15 (maximum). Move the X size and Y size sliders all the way 
to the right. Click the New Seed button, and make a note of the seed number. Then click OK to 
close the dialog.  



14. In the Layers dialog, click the dropdown to the right of Mode, and select Overlay. You should get 
a result similar to the image below. 

 

As you can see, the noise filter has created a fractal-like effect, randomizing the edge of the 
coastline. 

15. Create a new layer, and label it “Land Clip”. Fill this layer with white. 
16. Change the blend mode for the Land Clip layer to Lighten only. Refer to step 14 if you need a 

reminder on how to change the blend mode. The image will remain white—this is the correct 
outcome. 

17. In the main image window, with the Land Clip layer still selected, click Colors>Levels. This opens 
the Adjust Color Levels dialog. 



18. In the Adjust Color Levels dialog, locate the Output Levels sliders. There is a black slider on the 
left, and a white slider on the right. Move the white slider toward the left, and as you do the 
land mass in your image will slowly be revealed. Keep moving the slider until you are satisfied 
with how much of your landmass is showing. See the screenshot below for an example. Once 
you are satisfied, click OK. 

 

19. In the Tools dialog, click the Magic Wand tool. In the settings section at the bottom, make sure 
that Sample Merged is checked, and that the Threshold is set to 0. Then click in the dark area. 
You can adjust the Threshold setting if you want, to tighten up the selection. 

20. In the main image window, click Select>Invert to invert the selection. 
21. Create a new layer, with Layer Fill Type set to Foreground Color (black). Use the Bucket tool to 

fill in the selection with white. 
22. In the main image window, click Select>Save to Channel. In the Channels dialog you will see a 

new channel labeled “Selection Mask copy”. This will be used in a later step. 
23. Click Select>None to clear the selection in the main image window.  

The technique used in steps 8-23 creates three layers: shape, noise, and clip layers. RobA calls this the 
Three-Layer Sandwich technique, or TLS. This technique will be used extensively in this tutorial series, to 
create many kinds of geographical features on your map. 



Save your file. Always use the native GIMP format (.xcf), as it retains all the data in your image, such as 
layers, channels, and transparency. 

Starting Your Map From Scratch 
The previous section assumed you already had a rough sketch to start with. This section shows three 
examples of random shape generation, which you can use as a base shape for your map. 

Example 1 
1. Create a new file, with a white background. 
2. Click on the foreground color (default is black) to open the Change Foreground Color dialog. 

Next to the V bar, move the slider to the right until the number showing is at 50. Alternatively, 
you can just type 50 in the number field at the right. This creates a 50% gray color. Click OK to 
set the foreground color to this gray. 

3. Using the Bucket tool, fill your layer with this gray color. 
4. Create a new layer named “Noise”. In the main image window, click 

Filters>Render>Clouds>Solid Noise. In the dialog, keep the Detail at maximum (15), but set the 
X and Y sizes to around 5. Then click OK to close the dialog. 

5. Create a new layer named “Clip” and fill it with white. Change the blend mode to Lighten only. 
6. In the main image window, click Colors>Levels. In the Output Levels section, move the white 

slider to the right until you get some shapes that you like. Less gives you an island group, more 
gives you a landmass with lots of large lakes or inland seas. 

7. Select the Magic Wand tool. Make sure Sample Merged is checked, and Threshold is set to 0. 
Click the darker areas. Hold down the Shift key to select multiple dark areas. 

8. Invert your selection by clicking Select>Invert in the main image window. 
9. Create a new layer filled with black, named “Mask”. Fill the selection with white. Click 

Select>Save to Channel to save the selection. Then click Select>None to clear the selection. 
10. Your Mask layer should end up with a result similar to the image below.

 



Example 2 
1. Create a new file, with a white background. 

2. Select the Gradient Fill  tool. Keep the default settings. 
3. Click in one corner of your image, and drag diagonally across the image. This creates a linear 

gradient at an angle. If you don’t like the first one you create, press Ctrl-Z to undo and try again. 
4. Create a new layer named “Noise”. In the main image window, click 

Filters>Render>Clouds>Solid Noise. In the dialog, keep the Detail at maximum (15), but set the 
X and Y sizes to around 5. Then click OK to close the dialog. 

5. Change the layer blend mode of the Noise layer to Overlay. 
6. Create a new layer named “Clip” and fill it with white. Change the blend mode to Lighten only. 
7. In the main image window, click Colors>Levels. In the Output Levels section, move the white 

slider to the right until you get a shape that you like. You should end up with a coastline and 
large landmass area. 

8. Select the Magic Wand tool. Make sure Sample Merged is checked, and Threshold is set to 0. 
Click the darker areas. Hold down the Shift key to select multiple dark areas. 

9. Invert your selection by clicking Select>Invert in the main image window. 
10. Create a new layer filled with black, named “Mask”. Fill the selection with white. Click 

Select>Save to Channel to save the selection. Then click Select>None to clear the selection. 
11. Your Mask layer should end up with a result similar to the image below. 

 

 



Example 3 
1. Create a new file, with a white background. 
2. Select the Gradient Tool. In the settings section at the bottom, click the dropdown next to Shape 

and select Radial. 
3. Click in the center of your image, and drag to one of the corners. This should create a round 

shape that is light in the center and dark at the edge. If you have a shape that is dark in the 
center and light at the edge, you need to reverse the gradient in the settings for the Gradient 
tool. 

4. Create a new layer named “Noise”. In the main image window, click 
Filters>Render>Clouds>Solid Noise. In the dialog, keep the Detail at maximum (15), but set the 
X and Y sizes to around 5. Then click OK to close the dialog. 

5. Change the layer blend mode of the Noise layer to Overlay. 
6. Create a new layer named “Clip” and fill it with white. Change the blend mode to Lighten only. 
7. In the main image window, click Colors>Levels. In the Output Levels section, move the white 

slider to the right until you get a shape that you like. The farther left you move the slider, the 
larger your island landmass will be. 

8. Select the Magic Wand tool. Make sure Sample Merged is checked, and Threshold is set to 0. 
Click the darker area.  

9. Invert your selection by clicking Select>Invert in the main image window. 
10. Create a new layer filled with black, named “Mask”. Fill the selection with white. Click 

Select>Save to Channel to save the selection. Then click Select>None to clear the selection. 
11. Your Mask layer should end up with a result similar to the image below. 
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