
Using GIMP to Create an Artistic Regional 
RPG Map – Part 2 
This tutorial series is an updated and revised edition of an original tutorial created by RobA for the 
Cartographer’s Guild (www.cartographersguild.com). Updates and revisions to the instructions, along 
with new screenshots, were created by Megan Wiseman (“wisemoon” on Cartographer’s Guild). 

Part 1 gave instructions on how to create the basic landmass outline for your map, including some ideas 
on how to randomly generate a landmass shape if you don’t have a sketch to start with. This part starts 
with a section on how to create the ocean/sea if you are making a coastline map. If your map does not 
have a coastline, you may be able to use this technique for large, land-locked bodies of water (think the 
Great Lakes). Otherwise, just move on to the next section. 

Creating the Ocean or Sea 
1. Open the file from Part 1 of the tutorial, if you don’t already have it open. 
2. In the Layers dialog, right-click on the Land Mask layer, and select Duplicate Layer. Name this 

new layer “Sea Shape”. You can rename the layer by right-clicking the layer and selecting Edit 
Layer Attributes. 

3. In the main image window, click Filter>Blur>Gaussian Blur. This opens the Gaussian Blur dialog. 
4. In the settings, choose a large enough pixel size to create a gradient between black and white in 

your picture. In the example below, I chose 800 pixels. 

 

http://www.cartographersguild.com/


5. Create a new layer named “Sea Noise”. 
6. In the main image window, click Filters>Render>Clouds>Solid Noise. This opens the Solid Noise 

dialog. 
7. In the dialog, set the Detail to maximum (15) and set the X and Y sizes to around 3. Then click 

OK to close the dialog. 
8. Change the layer blend mode on the Sea Noise layer to Overlay. Merge this layer with the Sea 

Shape layer by right-clicking the Sea Noise layer and selecting Merge Down. 
9. Right-click the Sea Shape layer and select Duplicate Layer. Name this new layer “Sea”. 
10. Right-click the Sea layer and select Add Layer Mask. This opens the Add Layer Mask dialog. 
11. Under Initialize Layer Mask To, click the radio button next to Channel. It displays the Selection 

Mask channel we created in Part 1 of the tutorial. Check the box next to Invert Mask. Then click 
Add to close the dialog. 

12. Layer masks are used to cover some parts of the layer and reveal other parts. Where the mask is 
white, the layer shows through. Where the mask is black, the layer is hidden. Shades of grey 
show some of the layer in varying degrees of opacity. Right-click on the Sea layer and select 
Apply Layer Mask. This integrates the mask with the layer. 

13. With the Sea layer selected, click Colors>Auto>Normalize. 
14. Open the Histogram dialog if you don’t already have it open. If you look at the histogram, you 

can see there are gaps in the solid black. 
15. Right-click on the Sea layer and select Alpha to Selection. This selects all transparent areas in the 

layer. Click Select>Invert in the main image window to invert the selection. Now we have all 
non-transparent areas selected. 

16. Use the Bucket tool to fill the selected area with white. Then click Select>None to clear the 
selection. 

17. Click Filters>Blur>Gaussian Blur to open the Gaussian Blur dialog. Set the Blur radius to 20 
pixels, and then click OK. You should see that all the gaps in the Histogram are now filled in. 

18. In the Palette editor, click on the darkest water color (water 5). This sets the foreground color to 
that dark blue. Press the Ctrl key and click the lightest water color. This sets the background 
color to that light blue. 

19. With the Sea layer selected, click Colors>Map>Gradient Map. This should fill the layer with a 
gradient of blue, as shown below. If you do not get a gradient of blue, make sure your layer is 



set to RGB color mode by clicking Image>Mode and selecting RGB. 

 
20. Create a new layer and name it “Seashore”. Fill it with the lightest water color (water 1). 
21. Right-click the Seashore layer, and select Add Layer Mask. In the Add Layer Mask dialog, click 

the radio button next to Channel, which should have the Selection Mask or Land Mask channel 
as default. Make sure the box next to Invert Mask is unchecked. Then click Add to close the 
dialog. 

22. Once you create the mask, you should be in editing mode for the mask itself. In the Layers 
dialog, make sure that the layer mask has a white outline—this means you are in editing mode. 
You can click the layer thumbnail or the mask thumbnail to change which you are editing. Right 
now, we want to edit the mask. 

23. In the main image window, click Filters>Blur>Gaussian Blur. In the Gaussian Blur dialog, set the 
Blur Radius to 10 pixels. Then click OK to close the dialog. 

24. In the main image window, click Filters>Map>Displace. In the Displace dialog, set the X 
displacement to 20 and the Y displacement to -20. Click the dropdown box next to X 
displacement, and select the Land Noise layer. Do the same for the Y displacement dropdown. 
Leave the Displacement Mode set to Cartesian. Under Edge Behavior, click the radio button 
next to Smear. Then click OK to close the dialog. 

25. Now repeat step 24, except set the X displacement to -20 and the Y displacement to 20. Leave 
the other settings the same. On steps 24-25 you may want to increase the displacement to 25 or 
30, depending on the size of your map and how much of the wispy shoreline effect you want. 



Building Up the Landmass 
1. Duplicate the Sea Shape layer, and name the new layer “Grass”. Move the new layer to the 

top of your layer stack. 
2. Right-click the Grass layer, and select Add Layer Mask. In the Add Layer Mask dialog, click 

the radio button next to Channel (the Selection Mask should be the default). Make sure the 
Invert Mask box is unchecked. Then click Add to close the dialog. 

3. In the palette editor, press Ctrl and click the dark green (ditch) color. This makes that color 
the background color. Then click on the lightest green (high ground) to make it the 
foreground color. 

4. In the main image window, click Colors>Map>Gradient Map. A green gradient is applied to 
the landmass. 

5. Create a new layer, and name it “Grass Texture”. 
6. In the main image window, click Filters>Render>Clouds>Solid Noise. In the Solid Noise 

dialog, set the Detail to maximum (15), and the X and Y sizes to 3. Click the New Seed 
button to get a random seed. Then click OK to close the dialog. 

7. Right-click the Grass Texture layer, and repeat step 2 to add a layer mask to this layer. 
8. In the Layers dialog, change the layer blend mode of the Grass Texture layer to Overlay. 
9. Create a new layer, and name it “Grass Bump Map”.  
10. In the main image window, click Filters>Render>Clouds>Solid Noise. In the Solid Noise 

dialog, set the Detail to maximum (15), and the X and Y sizes to maximum (16). Click the 
New Seed button to get a random seed. Check the box next to Turbulent. Then click OK to 
close the dialog. 

11. Click the eye icon to hide the Grass Bump Map layer. 
12. Create a new layer, and name it “Grass Bumps”. Fill this layer with 50% gray. You can do this 

by clicking the foreground color swatch to open the Change Foreground color dialog, then 
typing 50 in the field across from V (Value). Click OK to close the dialog. Then use the Bucket 
tool to fill the layer. 

13. Change the layer blend mode for the Grass Bumps layer to Overlay. This will make the layer 
seem to disappear—that is the expected result. 
  



15. In the main image window, click Filters>Map>Bump Map. In the Bump Map dialog, click the 
dropdown next to Bump Map, and select the Grass Bump Map layer. Click the dropdown 
next to Map Type, and select Sinusoidal. Set the Azimuth to 120, the Elevation to 45, and 
leave the Depth at 3. When you get more practiced at the methods in this tutorial, you can 
fiddle with the settings to create different effects. Then click OK to close the dialog. See the 
screenshot below to locate the fields in this step. 

 

  



17. Right-click the Grass Bumps layer, and repeat step 2 to add a layer mask to this layer. Your 
result should look similar to the example below.

 
18. Create a new layer and name it “Dirt”. Fill this new layer with the second dirt color in the 

palette (med dirt). 
19. In the main image window, click Filters>Noise>HSV Noise to open the HSV Noise dialog. 

  



21. In the HSV Noise dialog, set the Holdness to 4, the Hue to 11, the Saturation to 10 and the 
Value to 22. See the screenshot below for help in locating these settings. Then click OK to 
close the dialog. 

 

22. In the main image window, click Filters>Map>Bump Map. In the Bump Map dialog, click the 
dropdown box next to Bump Map and click the Dirt layer. Leave the Map Type on 
Sinusoidal, and leave the Azimuth and Elevation settings the same. Change the Depth 
setting to 7. Then click OK to close the dialog. Refer back to step 15 if you need help locating 
the settings. 

23. Duplicate the Land Mask layer, and move it to the top of the layer stack. 
24. In the main image window, click Filters>Blur>Gaussian Blur. In the Gaussian Blur dialog, set 

the Blur Radius to 50 pixels. You may want to increase or decrease the size of the blur 
depending on the size of your map. 

25. Create a new layer and name it “Dirt Noise”.  
26. In the main image window, click Filters>Render>Clouds>Solid Noise. In the Solid Noise 

dialog, set the Detail to maximum (15), and the X and Y sizes to maximum (16). Click the 
New Seed button to get a random seed. Then click OK to close the dialog. 



27. Set the layer blend mode of the Dirt Noise layer to Difference. Your image should now show 
a dark outline around the coastline. 

28. Right-click the Dirt Noise layer and selecting Merge Down. This merges the Dirt Noise layer 
with the Land Mask copy layer. 

29. In the main image window, click Colors>Invert. This turns the coastal outline to white. 
30. In the main image window, click Colors>Levels to open the Levels dialog. Move the black 

and white slider in toward the middle, so that you end up with more contrast, and large 
areas of both black and white. See the screenshot below for an example. Then click OK to 
close the dialog. 

 

31. Rename this layer “Dirt Noise Mask”, as we are going to use this as a mask for the dirt. Then 
click the eye icon to hide it for now. 

32. Right-click the Dirt layer and repeat step 2 to add a layer mask to this layer. Then right-click 
the layer mask you just added, and select Apply Layer Mask. 

33. Right-click the Dirt Noise Mask layer and repeat step 2 to add a layer mask to this layer. 
34. Click the layer thumbnail to put it in editing mode, then click Filters>Blur>Gaussian Blur. In 

the Gaussian Blur dialog, set the Blur Radius to 10 pixels. Then click OK to close the dialog. 
35. In the main image window, click Filters>Noise>Spread. In the Spread dialog, set the Spread 

Amount to 10 pixels. Then click OK to close the dialog. 



36. Right-click the layer mask on the Dirt Noise Mask layer, and select Apply Layer Mask. 
37. Press Ctrl-A to select everything on the Dirt Noise Mask layer, and then press Ctrl-C to copy 

it. 
38. Right-click the Dirt layer and repeat step 2 to add a layer mask to this layer. Press Ctrl-V to 

paste, creating a floating layer. Right-click the floating layer and select Anchor Layer. This 
pastes the contents of the Dirt Noise Mask layer into the layer mask for the Dirt layer. You 
should get a result similar to the example below. 

 

• IF your map has desert areas included, continue to step 39. 
• IF your map does not have desert areas, skip to step 40. 

39. Move your original sketch up to the top of the layer stack, and set its layer blend mode to 
Burn. This will display the outlines of your map over all the layers. If you have some areas on 
your map that are desert, you can edit the layer mask by selecting a soft brush, setting the 
opacity of the brush to 60%, and coloring in the areas of desert. Make sure the foreground 
color is set to black. This will block out the grass for those areas that you painted. 



40. Click the Dirt layer thumbnail, and change the Opacity of the layer to around 50-60%. Play 
around with the opacity settings until the Dirt and Grass colors blend to your satisfaction. 

41. With the oceans colored in and grass and dirt added to the landmass, your result should 
look similar to the example below. 

 

This concludes Part 2. In Part 3 we will be creating mountains and forests to our landmass. 
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